[DAQ-drivers] driver/gtp branch, devel, updated. bf068c7b434ca1d157c4f2e891235e60f739c3dd
Bryan Moffit
moffit at jlab.org
Fri May 9 11:08:52 EDT 2014
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "driver/gtp".
The branch, devel has been updated
via bf068c7b434ca1d157c4f2e891235e60f739c3dd (commit)
via 73c8d8509c8b4c0c15c6c8568ab20ac3f56ee8f0 (commit)
via cf2b5c6e39e3ed39583fdaf2292bcdea53895c60 (commit)
via 8728f8414255259bdee61e3071d9325f5e4a1ce0 (commit)
via 799c31f07a2e8c6c7a72f33657809c5e85b9f3e4 (commit)
via 063bc38a887a97ce36dcb89d02f652b12890fc2a (commit)
via 5df7e936f466eba9148903f6d67a4e087a4b3e9c (commit)
via 000b8e36d615315cb4e0de978c024c8c4ec58570 (commit)
via 26518deb3e509071d8d3a43815219ed062aad932 (commit)
via 9fce5fe181e4ea1fe0a437822350c658e7dcdcc9 (commit)
via 78029d0485ceb3167bd8da83bf8205fbc8de48f3 (commit)
from e8996a0612c73d52ce91193287d56c7975fc8ea6 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit bf068c7b434ca1d157c4f2e891235e60f739c3dd
Author: Bryan Moffit <moffit at jlab.org>
Date: Fri May 9 11:08:30 2014 -0400
gtpLib.c
- Fix name of trigbit parameter
commit 73c8d8509c8b4c0c15c6c8568ab20ac3f56ee8f0
Author: Bryan Moffit <moffit at jlab.org>
Date: Fri May 9 11:02:51 2014 -0400
Nearly ready for release..
gtpLib.{c,h}
- Fix error in memory map. Reserved0 array wasn't large enough in
GtpCfg_regs
- gtpStatus
- Rename section to Payload Input Configuration
SHow Latency, lane bit errors
- Fill in section for Trigger Peripheral Configuration
- Fill in section on Trigger Out bits
- gtpCheckAddresses
- Routine to check offsets of the memory map
- Rename GTP_TRIG_SS to GTP_TRIGPER_
- Add in array of trigger peripheral names
- Rename
enum GTP_TRIG_SS_PARAMETERS
to
enum GTP_TRIG_PERIPHERAL
commit cf2b5c6e39e3ed39583fdaf2292bcdea53895c60
Author: Bryan Moffit <moffit at jlab.org>
Date: Fri May 9 00:52:39 2014 -0400
Makefile
- make install by default
- install/link all headers (not just those with *Lib.h)
gtpLib.{c,h}
- Move gtpVMELib.h and gtpSocket.h to gtpLib.h
- gtpGetTrigoutReg:
Changed from returning pointer to unsigned int
- Added subsystem names by payload port number
- gtpStatus
Good start to status output
gtpSocket.{c,h}
- New routines
char *gtpSocketGetHostname()
int gtpSocketGetPort()
gtpVMELib.c
- Change main pointer name so that it doesn't conflict with
that in gtpLib.c
commit 8728f8414255259bdee61e3071d9325f5e4a1ce0
Author: Bryan Moffit <moffit at jlab.org>
Date: Thu May 8 22:06:23 2014 -0400
Makefile
- Build libgtp.a instead of libgtpVME.a
- Include Makefile as dependency for object creation
- Include all objects in .a file
gtpLib.{c,h}
- Include other gtp headers
- Make gtpBase an unsigned long.
- gtpInit:
- Use i2c to initialize and get CPU status and hostname
- Add addition argument: hostname.
If set, don't use I2C to determine hostname
- Fix bug in macro for minor rev mask
- Fix boardid macro
gtpSocket.{c,h}
- include netdb.h
- Put all structs and macros in .c
- rename CRATEMSG to GTPSOCKET
- Make CrateMsgStruct Msg static
- Define cmcRead32 and cmcWrite32 to do what we want it to
- gtpSocketInit:
- Use addrinfo prescription to connect to GTP Server using
hostname, instead of ip address
- More error information if any communication fails.
- Add in routine prototypes to header
gtpVMELib.{c,h}
- Short byte swap some i2c for now... until firmware gets fixed
- Fix bug in macro for minor rev mask
- Fix boardid macro
commit 799c31f07a2e8c6c7a72f33657809c5e85b9f3e4
Author: Bryan Moffit <moffit at jlab.org>
Date: Thu May 8 17:54:41 2014 -0400
Makefile
- Build in gtpSocket library
gtpSocket.{c,h}
- Initial commit of library to handle communication with GTP
Ethernet socket.
- Nearly complete. Untested... but it compiles. Mostly ported
from Ben's client made from the ROOT TSocket implementation.
commit 063bc38a887a97ce36dcb89d02f652b12890fc2a
Author: Bryan Moffit <moffit at jlab.org>
Date: Thu May 8 16:10:31 2014 -0400
gtpLib.{c,h}
- gtpMutex defined within gtpVMELib.c
- define GTPLOCK/UNLOCK only if it's not already defined
- rename some routines improperly named: getGet* to gtpGet*
- New routines:
int gtpGetSubsystemDelay(int ss);
int gtpGetSubsystemWidth(int ss);
int gtpSetTriggerBitEnableMask(int trigout, int trigbitMask);
int gtpGetTriggerBitEnableMask(int trigout);
int gtpSetTrigoutLatencyWidth(int trigout, int latency, int width);
int gtpGetTrigoutLatency(int trigout);
int gtpGetTrigoutWidth(int trigout);
int gtpGetTrigoutStatus(int trigout);
int gtpSetTrigoutParameter(int trigout, int param, int value);
unsigned int gtpGetTrigoutParamter(int trigout, int param);
commit 5df7e936f466eba9148903f6d67a4e087a4b3e9c
Author: Bryan Moffit <moffit at jlab.org>
Date: Thu May 8 11:35:45 2014 -0400
Makefile
- recipe for compiling individual .o from .c
gtpLib.{c,h}
- gtpGetSyncSource:
- Fix macro name typos
- Bug in error message
- gtpGetChannelUpMask, gtpEnableBitErrorCountersMask
- missing variable declaration
- new routines
int gtpSetTriggerEnableMask(int trigmask)
int gtpGetTriggerEnableMask()
int gtpSetSubsystemDelayWidth(int ss, int delay, int width)
int getGetSubsystemDelay(int ss)
int getGetSubsystemWidth(int ss)
commit 000b8e36d615315cb4e0de978c024c8c4ec58570
Author: Bryan Moffit <moffit at jlab.org>
Date: Thu May 8 10:26:21 2014 -0400
gtpLib.{c,h}
- Added: Clock, Trig, Sync setup. Enable serial links.
- Reorganized some of the header file
- Added some new masks and bit definitions.
commit 26518deb3e509071d8d3a43815219ed062aad932
Author: Bryan Moffit <moffit at jlab.org>
Date: Fri Apr 25 16:51:47 2014 -0400
Initial commit of socket ethernet version of GTP library.
commit 9fce5fe181e4ea1fe0a437822350c658e7dcdcc9
Author: Bryan Moffit <moffit at jlab.org>
Date: Wed Apr 9 11:08:50 2014 -0400
Forgot to include gtpVMELib.h
commit 78029d0485ceb3167bd8da83bf8205fbc8de48f3
Author: Bryan Moffit <moffit at jlab.org>
Date: Wed Apr 9 11:05:35 2014 -0400
Updates to current i2c registers. Library name change (for i2c).
Makefile
- Standardize.. make similar to other linuxvme Makefiles
- Change names from gtpLib to gtpVMELib
gtpLib.{c,h}
- Removed... older firmware that's no longer relevant
gtpVMELib.{c,h}
- Library for getting status of GTP through TI i2c
- Pretty much complete... just needs tested.
test/*
- Added some library test routines.
-----------------------------------------------------------------------
Summary of changes:
Makefile | 38 +-
gtpLib.c | 1272 +++++++++++++++++++++++++++++++++++++++--------------
gtpLib.h | 527 +++++++++++++++++++----
gtpSocket.c | 475 ++++++++++++++++++++
gtpSocket.h | 52 +++
gtpVMELib.c | 290 ++++++++++++
gtpVMELib.h | 58 +++
test/Makefile | 34 ++
test/gtpLibTest.c | 51 +++
9 files changed, 2373 insertions(+), 424 deletions(-)
create mode 100644 gtpSocket.c
create mode 100644 gtpSocket.h
create mode 100644 gtpVMELib.c
create mode 100644 gtpVMELib.h
create mode 100644 test/Makefile
create mode 100644 test/gtpLibTest.c
hooks/post-receive
--
driver/gtp
More information about the Daq-drivers
mailing list